InnoDB: Unable to lock ./ibdata1, error: 11

Ошибка выглядит следующим образом:

InnoDB: Unable to lock /path/to/ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.

Чтобы исправить ошибку, делаем следующие шаги:

/etc/init.d/mysql stop
mv /var/lib/mysql/ibdata1 /var/lib/mysql/ibdata1.bak
cp -a /var/lib/mysql/ibdata1.bak /var/lib/mysql/ibdata1

Запускаем сервис mysql:

/etc/init.d/mysql start

Настройка IPTV на маршрутизаторе Cisco 871

Данная статья поможет настроить IPTV тем, у кого дома стоит маршрутизатор компании Cisco Systems.
Конфигурация протестирована на операторе связи «ТИС-ДИАЛОГ» http://iptv.tis-dialog.ru и показала свою работоспособность.

Конфигурация ниже:
!
ip cef
ip multicast-routing
!
interface FastEthernet4
description –WAN PPPoE source interface–
ip address 172.21.0.20 255.255.255.0
no ip proxy-arp
ip pim sparse-dense-mode
ip nat outside
ip virtual-reassembly
ip tcp adjust-mss 1360
ip igmp query-interval 125
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable
hold-queue 175 in
!
interface Vlan1
description –LAN interface–
ip address 10.11.12.1 255.255.255.0
no ip proxy-arp
ip pim sparse-dense-mode
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1360
ip igmp helper-address 172.21.0.254
!
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 172.20.2.0 255.255.255.0 172.21.0.254
!
!
no ip http server
no ip http secure-server
ip nat inside source list 102 interface Dialer1 overload
!

Виктор Пелевин «S. N. U. F. F.»

— Если ты когда-нибудь сможешь разогнать свой вялый ум настолько, чтобы увидеть себя как есть, — продолжала она, — ты поймешь главное. Твои мысли, желания и импульсы, заставляющие тебя действовать — на самом деле вовсе не твои. Они приходят к тебе из совершенно неясного пространства, как бы ниоткуда. Ты никогда не знаешь, чего тебе захочется в следующую секунду. Ты в этом процессе просто свидетель. Но твой внутренний свидетель настолько глуп, что немедленно становится участником преступления — и огребает по полной программе…

Виктор Пелевин «S. N. U. F. F.»

- Дважды два – четыре только по той причине, что тебя в детстве долго пороли, – сказал дискурсмонгер, – и ещё потому, что четыре временно называется «четыре», а не «пять». Когда добивали последних неандертальцев, никакой правды за ними не осталось, хоть до этого она была с ними миллионы лет. Правда там, где жизнь. А где нет жизни, нет ни правды, ни лжи.
- Но нельзя же так промыть мозги… – начал Грым.
- История человечества, – перебил дискурсмонгер, – это история массовых дезинформаций. И не потому что люди глупые и их легко обмануть. Люди умны и проницательны. Но они с удовольствием поверят в самую гнусную ложь, если в результате им устроят хорошую жизнь. Это называется «общественный договор». Промывать мозги никому не надо – они у цивилизованного человека всегда чистые, как театральный унитаз.

Виктор Пелевин «S. N. U. F. F. «

Зачем диверсия. Тут и диверсии никакой не надо.. Во-первых, у нас считают, что инженер – это низшая каста. А герой нашего времени – это вертухай с хатой в Лондоне. Или на худой конец какой-нибудь филологический говнометарий, которого в университете семь лет учили фигурно сосать у кагана. Особенно если он в Желтую зону пролез и не только у кагана сосет, но и у верхних. А я при них типа слуга-механик. А теперь подумай, зачем я, инженер, стану наживать себе грыжу? Поднимать к звездам этих орлов? Да пусть они в говне утонут со своим «Словом о Слове»…

Виктор Пелевин «Священная книга оборотня»

Говоря о вине интеллигенции перед народом, он постоянно употреблял два термина, которые казались мне синонимами, – «интеллигент» и «интеллектуал». Я не выдержала и спросила:
- А чем интеллигент отличается от интеллектуала? – Различие очень существенное, – ответил он. – Я берусь объяснить только аллегорически. Понимаете, что это значит?
Я кивнула.
- Когда вы были совсем маленькая, в этом городе жили сто тысяч человек, получавших зарплату за то, что они целовали в зад омерзительного красного дракона. Которого вы, наверно, уже и не помните…
Я отрицательно покачала головой. Когда-то в юности я действительно видела красного дракона, но уже забыла, как он выглядел, – запомнился только мой собственный страх. Павел Иванович вряд ли имел в виду этот случай.
- Понятно, что эти сто тысяч ненавидели дракона и мечтали, чтобы ими правила зеленая жаба, которая с драконом воевала. В общем, договорились они с жабой, отравили дракона полученной от ЦРУ губной помадой и стали жить по-новому.
- А при чем тут интелл…
- Подождите, – поднял он ладонь. – Сначала они думали, что при жабе будут делать точь-в-точь то же самое, только денег станут получать в десять раз больше. Но оказалось, что вместо ста тысяч целовальников теперь нужны три профессионала, которые, работая по восемь часов в сутки, будут делать жабе непрерывный глубокий минет. А кто именно из ста тысяч пройдет в эти трое, выяснится на основе открытого конкурса, где надо будет показать не только высокие профессиональные качества, но и умение оптимистично улыбаться краешками рта во время работы…
- Признаться, я уже потеряла нить.
- А нить вот. Те сто тысяч назывались интеллигенцией. А эти трое называются интеллектуалами.

Виктор Пелевин «Священная книга оборотня»

Если бросить палку собаке, она будет глядеть на эту палку. А если бросить палку льву, то он будет, не отрываясь, смотреть на кидающего. Это формальная фраза, которую говорили во время диспутов в древнем Китае, если собеседник начинал цепляться за слова и переставал видеть главное.

Виктор Пелевин «Чапаев и пустота»

С чем пирожки-то? — нежно спросил Барболин. — Говорят, тут люди пропадают…

Apache: исключить один url из Basic Auth

В данном примере мы будем использовать модуль mod_setenvif: http://httpd.apache.org/docs/2.2/mod/mod_setenvif.html

<Location /security/>
# set an environtment variable "noauth" if the request starts with "/callbacks/"
SetEnvIf Request_URI ^/security/openzone/ noauth=1

# auth block
AuthName "ACCESS ZONE"
AuthType Basic
AuthUserFile /www/mysite.ru/.htpasswd

# Here is where we allow/deny
Order Deny,Allow
Satisfy any
Deny from all
Require valid-user
Allow from env=noauth
</Location>

Cisco ASA: настроить ssh доступ

Итак, нам нужно настроить доступ SSH для управления железкой. Приступим:

Определим имя железки

hostname cisco-asa

Домен

ip domain-name mycompany.local

Сгенерируем ключ:

crypto key generate rsa

Настраиваем параметры аутентификации

aaa authentication ssh console LOCAL
username LOGIN password PASSWORD
password PASSWORD

(далее…)