Cisco ASA: failed to establish VPN through ASA/PIX

Для того чтобы работало PPTP подключение у клиентов ASA, находящихся за НАТ-ом, нужно просто прописать:

ipfwnode01(config)# fixup protocol pptp 1723

В конфигурации появится следующие строки:

!
policy-map global_policy
 class inspection_default
  inspect pptp
!

Значит все окей, проверяем подключение.

Настройка IPTV на маршрутизаторе Cisco 871

Данная статья поможет настроить IPTV тем, у кого дома стоит маршрутизатор компании Cisco Systems.
Конфигурация протестирована на операторе связи «ТИС-ДИАЛОГ» http://iptv.tis-dialog.ru и показала свою работоспособность.

Конфигурация ниже:
!
ip cef
ip multicast-routing
!
interface FastEthernet4
description –WAN PPPoE source interface–
ip address 172.21.0.20 255.255.255.0
no ip proxy-arp
ip pim sparse-dense-mode
ip nat outside
ip virtual-reassembly
ip tcp adjust-mss 1360
ip igmp query-interval 125
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable
hold-queue 175 in
!
interface Vlan1
description –LAN interface–
ip address 10.11.12.1 255.255.255.0
no ip proxy-arp
ip pim sparse-dense-mode
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1360
ip igmp helper-address 172.21.0.254
!
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 172.20.2.0 255.255.255.0 172.21.0.254
!
!
no ip http server
no ip http secure-server
ip nat inside source list 102 interface Dialer1 overload
!

Введение в протокол OSPF (Single area OSPF)

Введение

В данном разделе мы рассматриваем базовую конфигурацию, single-area OSPF

Более сложная конфигурация (multi-areas OSPF) будет рассматриваться в курсе CCNP

Single-area OSPF – однообластная конфигурация

Multi-area OSPF – межобластная конфигурация

Основные шаги развития OSPF

  • Создан в 1987

  • В 1989 OSPFv1 описан в RFC 1131 (экспериментальная версия более не используется)
  • В 1991 OSPFv2 выпущен в RFC1247
  • В 1998 OSPFv3 обновлен в RFC2328
  • В 1999 OSPFv2 опубликован RFC2740

Структура OSPF

(далее…)

Введение в IP телефонию Cisco Call Manager #1. Часть2

Продолжение статьи «Введение в IP телефонию Cisco Call Manager«…

Устройства многоточечных аудио-видео конференций, их также называют MCU

(далее…)

Введение в IP телефонию Cisco Call Manager #1

Часть первая.

IP сети – это некие сети пакетной передачи данных которые не ориентированы на установление соединений. Любые пакеты которые «ходят» внутри этой сети приходят к получателю в хаотичном порядке, образуя задержки. Система IP телефонии обеспечивает маршрутизацию телефонного вызова от источника к назначению.

В любых пакетных сетях существуют множество факторов которые влияют на деградацию голоса:

1. Потеря пакетов

2. Задержки (на заметку: VoIP сети чувствительны к задержкам до 150мс)

3. Джиттер – это вариативная задержка которая возникает между пакетами след в сети, сам джиттер существ всегда, но если он выходит из под контроля и превышает некий допустимый порог, телефонная связь превращается в некое подобие симплекса.

(далее…)

CISCO ASA 5510: утечки памяти

В релизе IOS’а 8.2(1)11, как утверждает cisco.com есть некоторые баги, приводящие к утечке памяти:

Вывод в консоли покажет:

%ASA-3-211001: Memory allocation Error.

(далее…)

IP фрагментация, MTU, MSS, и PMTUD. Проблемы с GRE и IPSEC

Введение

Цель этого документа заключается в том, чтобы показать как работают IP Фрагментация и Path Maximum Transmission Unit Discovery (PMTUD) и обсудить некоторые сценарии, связанных с поведением PMTUD в сочетании с различными комбинациями IP туннелей. На сегодняшний день, использование IP туннелей приобретает массовый характер.

IP фрагментация и Реассемблирование
IP протокол был разработан для использования на самых различных каналах передачи данных. Несмотря на то, что максимальная длина IP датаграммы составляет 64К, многие каналы передачи данных требуют установить ограничение на меньшую максимальную длину пакета – MTU. Значение параметра MTU зависит от типа канала передачи данных.
IP Фрагментация – это разбиение датаграммы на множество частей, которые могут быть воссозданы позже: IP источника, назначения, идентификация, общая длина, и смещение фрагмента поля, вместе с флагами «более фрагментов» и «не фрагментировать» в заголовке IP, используются для IP фрагментации и повторной сборки пакетов. Для получения дополнительной информации о механике IP фрагментации и повторной сборке пакетов, см. RFC 791.

(далее…)

Зашифруйте Ключи Pre-shared в Примере Конфигурации маршрутизатора Cisco IOS

Зашифруйте Ключи Pre-shared в Примере Конфигурации маршрутизатора Cisco IOS

Содержание

Введение

Предварительные условия

Требования

Используемые компоненты

Условные обозначения

Конфигурация

Конфигурации

Введение

Релиз 12.3 Программного обеспечения CISCO IOS (2) код T вводит функциональные возможности, которые разрешают
маршрутизатору шифровать предварительный ключ ISAKMP в безопасном типе 6 форматов в энергонезависимой памяти (NVRAM).
Предварительный ключ, который будет зашифрован, может быть настроен или как стандарт, под кольцом ключей ISAKMP, в
агрессивном режиме, или как пароль группы под установкой клиента или сервером EzVPN. Этот пример конфигурации детализирует,
как установить шифрование и существующих и новых предварительных ключей.

(далее…)